Changeset fbdba88 in subsurface


Ignore:
Timestamp:
Jun 27, 2017, 8:52:12 PM (5 months ago)
Author:
Dirk Hohndel <dirk@…>
Branches:
master
Children:
f98fa50
Parents:
5265956
Message:

Update Subsurface-branch of libdivecomputer check

We now require the Subsurface-branch, and at least version 2 of the
Subsurface API of libdivecomputer.

Signed-off-by: Dirk Hohndel <dirk@…>

File:
1 edited

Legend:

Unmodified
Added
Removed
  • core/libdivecomputer.c

    rd01b7bf rfbdba88  
    1818#include "libdivecomputer.h"
    1919
    20 #if !defined(SSRF_LIBDC_VERSION)
    21 #pragma message "You are not compiling against the Subsurface branch of libdivecomputer"
    22 #pragma message "While this may still work, you are missing important features of Subsurface"
     20#if !defined(SSRF_LIBDC_VERSION) || SSRF_LIBDC_VERSION < 2
     21#pragma message "Subsurface requires a reasonably current version of the Subsurface-branch"
     22#pragma message "of libdivecomputer (at least version 2 of our API)."
    2323#pragma message "Please get it from http://github.com/Subsurface-divelog/libdc Subsurface-branch"
    24 #else
    25 #if !defined(SSRF_CUSTOM_IO)
    26 #pragma message "You are compiling against an older version of the Subsurface branch of libdivecomputer"
    27 #pragma message "which doesn't support the new SSRF_CUSTOM_IO model. Please update libdc"
    28 #endif
    2924#endif
    3025//
Note: See TracChangeset for help on using the changeset viewer.