Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#167 closed enhancement (worksasdesigned)

Mares IconHS Net Ready full integration

Reported by: jrg34567 Owned by: Subsurface Team
Priority: minor Component: Other
Version: 3.1 Keywords:
Cc: Plattform (please give specifics in the ticket text): Linux

Description

I am not sure if this is something the Subsurface team is even interested in doing, but it would be nice if Subsurface was fully integrated with the supported dive computers writing to them as well as reading from them.

I have suggested to Mares to work with the Subsurface team to fully integrate the IconHD Net Ready to be able to write the ICE info to the computer. Mares ticket #VLV-806-45570

Subsurface reads the IconHD just fine. It would just be nice to be everything in one program.

Change History (7)

comment:1 Changed 4 years ago by admin

We are working with Mares already - so please close that ticket with Mares.

The full integration is not gated by Mares but by our available resources.

comment:2 Changed 4 years ago by jrg34567

Will do.

comment:3 Changed 4 years ago by admin

This should now work when building with the latest of the release-0.4 branch of libdivecomputer. Can you verify this?

comment:4 Changed 4 years ago by jefdriesen

Downloading dives should work fine. But I think this ticket is about the other features that the Icon HD support, like the ICE (In Case of Emergency) info and other metadata. Unless I missed something that's not supported by subsurface nor libdivecomputer (unless it can be implemented by writing to the appropriate memory location, but I don't know if that's how it's supposed to be done).

comment:5 Changed 4 years ago by jrg34567

It is true that I was referring to writing to the Icon HD and not just reading from it.

I have been using the RPM from Fedora, subsurface-3.1.1-1.fc19.x86_64, and not building myself for a while. I am very actively developing for work right now. I will try to do a git pull and check, but it may take a few days to get to it.

comment:6 Changed 4 years ago by DirkHH

  • Resolution set to worksasdesigned
  • Status changed from new to closed

comment:7 Changed 4 years ago by jrg34567

OK, so it works as designed. Hence, the reason this was put in as an ENHANCEMENT, indicating that the design could be improved or enhanced.

Note: See TracTickets for help on using tickets.