Opened 4 years ago

Closed 4 years ago

#214 closed defect (fixed)

New dives are imported under dive number 0

Reported by: ThomasB Owned by: Subsurface Team
Priority: minor Component: Divecomputer Download
Version: 3.1 Keywords:
Cc: Plattform (please give specifics in the ticket text): Windows

Description

While downloading from my Suunto vytec, new dives are appended with dive number 0 up to, and including, the last dive in the dive log.
Last dive is shown twice but it's only a UI glitch because it's not duplicated in the XML.

Eg.

  • 0 <= new dive
  • 0 <= new dive
  • 13 <= previous last dive
  • 0 <= duplicate entry of dive 13 (ui glitch)
  • 12 <= previous dive
  • ...

Attachments (2)

2013-11-14_13h55_12.png (3.5 KB) - added by ThomasB 4 years ago.
Dive list
2013-11-16 18h02_30.mp4 (137.0 KB) - added by ThomasB 4 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 4 years ago by admin

I'm not sure I understand the issue. Maybe some screenshots (and step-by-step instructions how they were created / could be reproduced) would help?

Changed 4 years ago by ThomasB

Dive list

comment:2 Changed 4 years ago by ThomasB

Hi, Here are the steps to reproduce this problem :

  1. Open Subsurface
  2. Connect suunto Vytec
  3. in the toolbar, "Dive" > "Download from computer" (translated from french)
  4. press "Start"(translated from french)
  5. dives are downloaded + UI Glitch
  6. save and close subsurface
  7. Open subsurface

==> gives the attached screenshot

In the divelog you can see (simplified version) :
<dive number='71' date='2013-10-18' time='19:44:00' ...>
<dive number='72' date='2013-10-20' time='09:43:00' ...>
<dive date='2013-10-25' time='20:48:00' ...>
<dive date='2013-11-08' time='19:27:00' ...>
<dive date='2013-11-09' time='09:55:00' ...>

comment:3 Changed 4 years ago by admin

That's very strange. In a situation like that Subsurface should give the new dives consecutive numbers... How many dives are in your XML file? Are they consecutively numbered? Which number do they start with?

comment:4 Changed 4 years ago by ThomasB

Now, to be honnest, since I had to correct the numbers manually, I ended up with fancy numbers : some dives have no number, my dives start from 38 up to 72 (with holes ; to kep up with my paper divelog), ...

But I think it behaved the same at the begining.

Anyway, I would have expected subsurface to increment by 1 the last dive number.
To me this seems to be the best/easyest/cheapest way to do it since theses holes / duplicates dive numbers don't seem to bother subsurface at all...

comment:5 Changed 4 years ago by admin

My point is that it should. Unless something in the file completely throws it off.
If the existing dives (specifically, the LAST existing dive) is/are numbered and the new dives are ALL later than ALL of the existing dives, then the new dives should be numbered correctly.

So I'm trying to understand if your situation violates one of these conditions and if not why we don't do as we should...

comment:6 Changed 4 years ago by ThomasB

I'll try to do a video screen shot of it next time.

But no, It doesn't seem to violate your pre-conditions

comment:7 Changed 4 years ago by admin

In that case, if you don't mind... could you send me the XML file? I can always create a file that has "later dives" to add to it. That way I could hopefully debug why this fails (it obviously works for me, or I wouldn't keep asking these questions...)

TBH - I am just about to release an early beta of the next version of Subsurface. So I am mostly interested to make sure that it works with THAT :-)

comment:8 Changed 4 years ago by ThomasB

I'll try to do it in 3-4Hrs.

Since you're "admin", check my email and PM me (so that we don't post too much "blahblah comment")

Changed 4 years ago by ThomasB

comment:9 Changed 4 years ago by DirkHH

Hi Thomas,

We now have a second report of a very similar sounding issue (#302).

And just for the record, no, I really want to keep the conversation here on the bug tracker to make sure that other developers looking into it can see what's going on.

Could you try the beta of Subsurface-3.9 and tell me if this still happens there?

http://subsurface.hohndel.org/downloads/subsurface-3.9-Beta.exe

comment:10 Changed 4 years ago by ThomasB

Hi "admin"

Short story : problem solved in 3.9 and 3.1.1

I've installed 3.9 over 3.1 and computer download was not working anymore.
That's why I've uninstalled 3.9 and reinstalled 3.1.1.
After that both 3.9 and 3.1.1 were working perfectly ...

Thomas

comment:11 Changed 4 years ago by DirkHH

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.