Opened 3 years ago

Closed 3 years ago

#274 closed defect (invalid)

Cylinder tank size changes automatically to wrong value

Reported by: pwolter Owned by: tcanabrava
Priority: major Component: Qt-UI
Version: 3.9 BETA Keywords:
Cc: Plattform (please give specifics in the ticket text): Mac

Description

Editing gases for a decompression dive I found something weird.

I used Air as back gas, EAN50 and O2 for decompression. The EAN50 was an AL80 tank. I Enter the AL80, under size I entered 80, moved to WorkPress? and enter 3000 ... then Subsurface changed the Size to 576.9. I have to change it back to 80 and keep editing.

Also, it automatically populated the 36 and 32 percent tanks as shown in the print screen. Even I did not have them active on my computer and have not added them before.

It took me way to long to figure out how to delete a Cylinder ... would be good to add a right click "Delete, Add, Edit" menu or make the interface a little more intuitive adding a "Minus" clickable bottom (similar to the Plus one to add tanks) so people has a easy way to delete tanks..

Attachments (4)

Screenshot 2013-11-16 16.01.49.png (22.7 KB) - added by pwolter 3 years ago.
Tank weird behavior
snapshot2.png (148.8 KB) - added by tcanabrava 3 years ago.
icons
Screen Shot 2013-11-19 at 4.26.38 PM.png (142.0 KB) - added by pwolter 3 years ago.
New downloaded dive with more tanks that really used on the dive
Screen Shot 2013-11-19 at 4.27.11 PM.png (189.6 KB) - added by pwolter 3 years ago.
202 ft dive with wrong tanks orders

Download all attachments as: .zip

Change History (21)

Changed 3 years ago by pwolter

Tank weird behavior

comment:1 Changed 3 years ago by tcanabrava

The delete's a big 'trash' icon on the left of the table. it's hard to spot? ( no, not jocking, just trying to make thigs better. ).

For the change, are you on bar or psi ( in preferences ) ?
Either way, I tested with both here, and in Metric Systems, it didn't worked as you described,
and in Imperial system when you selected AL80, it correctly already filled size 80 and workpress 3000.

But since it went from 80 to 576, I *think* you were using Imperial Systems over the Metric settings, can you check?

comment:2 Changed 3 years ago by pwolter

I'm just using Imperial system, full not custom.

I can't see a trash icon anywhere, I have re sized the windows, I selected to view just "Info" and nothing.

comment:3 Changed 3 years ago by admin

Did you install Thiago's installer or build from source?
I wonder if maybe the icons are missing from the Mac installer. They appear to be currently not working correctly in the Windows installer.

comment:4 Changed 3 years ago by pwolter

I'm using Thiago's installer as I can't compile Subsurface anymore on Mavericks.

Changed 3 years ago by tcanabrava

icons

comment:5 Changed 3 years ago by tcanabrava

Can you post a screenshoot? Here's how it looks like on my pc, build from sources. ( img attached. )

comment:6 Changed 3 years ago by pwolter

Ok. I see the Trash icon now ... BUT I have to see your print screen to realize I have to "resize" the column *before* the tank in order to see it ... maybe the binary Thiago build is having weird behavior?

comment:7 Changed 3 years ago by tcanabrava

the default values for columns are broken, it's almost midnight here so I'll fix that tomorrow. :)

comment:8 Changed 3 years ago by admin

Ok, let's sum this one up:
a) Tomaz will improve the column width for the equipment tab so the trash can is always visible (just give that column a hard minimum width so people cannot shrink things
b) Pablo had very strange behavior when adding tanks... when selecting AL80 you should get size / working pressure already filled in. Don't you? And then, why did you get 576? Can you explain step by step what happened? Are you in "all imperial" mode?

comment:9 Changed 3 years ago by pwolter

Yes, I'm all Imperial mode. I just try to select a tank of size AL80 and the system automatically populates the wrong size ... even when I try to select a tank different than AL80 (example in other ticket HP119).

comment:10 Changed 3 years ago by admin

I'll install Thiago's binaries here to see if that's what triggers it. I cannot reproduce this either on Linux or Mac with my own binaries. Whatever I try.

comment:11 Changed 3 years ago by admin

Ahhhhh.
I can reproduce this with Thiago's binaries. Ok - that will be fun to track down. Not.

comment:12 Changed 3 years ago by pwolter

Please tell me you are able to see that the zoom in/out doesn't work with Thiago's binary ... and the AL80 and HP119 issue as well ...

comment:13 Changed 3 years ago by admin

I see the incorrect width of columns.
I see the "jump back to AL80".
I don't see the wrong size (as I scroll through the tanks, the correct size is shown).
I don't see the "zoom doesn't work".
(so I guess I posted this on the wrong bug...)

comment:14 Changed 3 years ago by henrik

«I see the "jump back to AL80"» is covered in #258

Changed 3 years ago by pwolter

New downloaded dive with more tanks that really used on the dive

Changed 3 years ago by pwolter

202 ft dive with wrong tanks orders

comment:15 Changed 3 years ago by DirkHH

OK, going through the bugs again...

This one is weird. I believe the only issue left is that the Petrel shows you tanks that you didn't use... correct? Or is there something else that's still wrong with 3.9.1?

comment:16 Changed 3 years ago by DirkHH

Can you confirm that this is still broken with the latest master? Or if you cannot build from source, with 3.9.2?

comment:17 Changed 3 years ago by DirkHH

  • Resolution set to invalid
  • Status changed from new to closed

Abandoned bug

Note: See TracTickets for help on using tickets.