Opened 4 years ago

Closed 4 years ago

#333 closed defect (fixed)

Yearly Statistics menu item crashes Subsurface

Reported by: pkonings Owned by: tcanabrava
Priority: major Component: Qt-UI
Version: 3.9.1 BETA Keywords:
Cc: Plattform (please give specifics in the ticket text): Windows

Description

Selecting View > Yearly Statistics crashes Subsurface under windows 7. Reproduced this with a new, empty divelog, with an existing divelog, and with a divelog that has been newly populated with dives from a DC. The crash occurs after selecting the Yearly Dives item by mouse and by shortcut key.

Error message: "subsurface dive log has stopped working" "A problem has caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." A button labeled "Close program" is shown.

Restarting subsurface does not solve the problem.

Change History (1)

comment:1 Changed 4 years ago by DirkHH

  • Resolution set to fixed
  • Status changed from new to closed

This bug has been fixed since the beta in commit 5a1a25a47604.
Assuming I don't run out of time, there should be a new beta later tonight which includes the fix.

Note: See TracTickets for help on using tickets.