Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#342 closed defect (fixed)

cant change weight type

Reported by: divelogs Owned by: tcanabrava
Priority: blocker Component: Qt-UI
Version: 3.9.2 BETA Keywords: weights
Cc: Plattform (please give specifics in the ticket text): Mac

Description

On OS-X Mavericks, it is not possible to change the weight type. Clicking on the field shows a dropdown, but no matter what the type is changed to, it switches back to the previous one immediately

Change History (6)

comment:1 Changed 4 years ago by DirkHH

That's odd. We had noticed this earlier with the cylinders #275 and fixed it there, but I can reproduce what you describe.

Tomaz, did we not fix this for the weight systems as well?

comment:2 Changed 4 years ago by DirkHH

  • Priority changed from minor to blocker

comment:3 Changed 4 years ago by tcanabrava

I cloned the fix you did for the cylinder, now we need to test. since I'm not sure it fixed as I don't own a mac, I'll leave this opened.

comment:4 Changed 4 years ago by henrik

  • Resolution set to fixed
  • Status changed from new to closed

Ack

comment:5 Changed 4 years ago by Dirk Hohndel <dirk@…>

In 0ac8ab307085d297a7615eb7385314762b144bce/subsurface:

Add support for Shearwater Desktop XML logs

Fixes #342

Signed-off-by: Miika Turkia <miika.turkia@…>
Signed-off-by: Dirk Hohndel <dirk@…>

comment:6 Changed 4 years ago by DirkHH

Oops - flipped two numbers around in a commit... the previous comment is way off - that's about #432

Note: See TracTickets for help on using tickets.