Opened 3 years ago

Closed 3 years ago

#365 closed enhancement (fixed)

Wrong behaviour when switching gas in Add Dive dialog

Reported by: henrik Owned by: tcanabrava
Priority: minor Component: Qt-UI
Version: current git - add SHA in description Keywords:
Cc: Plattform (please give specifics in the ticket text): Linux

Description

1) Add a new dive (see initial.png)
2) Add a second gas with 32% O2
3) Right-click the third node in the graph (just before the ascent), and select EAN32 (see 2nd-node-ean32.png)

Now several things are wrong:

a) The vector between the second and third node says "EAN32". It should be between the third and fourth. (And maybe on all vectors after the second node)

b) When I save the dive, the gas change is on the second node (just after the descent), not the third. (see gas-change-on-2nd.png)

Attachments (4)

initial.png (59.4 KB) - added by henrik 3 years ago.
2nd-node-ean32.png (65.9 KB) - added by henrik 3 years ago.
ean32-between-2nd-and-third.png (61.1 KB) - added by henrik 3 years ago.
gas-change-on-2nd.png (77.1 KB) - added by henrik 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by henrik

Changed 3 years ago by henrik

Changed 3 years ago by henrik

Changed 3 years ago by henrik

comment:1 Changed 3 years ago by henrik

I'm unable to edit the text, so I'll just add it here instead: The parantheses in pt. a) should say "(And maybe on all vectors after the third node)"

comment:2 Changed 3 years ago by henrik

Related issue: It's not possible to change gas on the first node, since it doesn't have a right-clickable small white circle like the rest of the nodes.

comment:3 Changed 3 years ago by DirkHH

  • Resolution set to worksasdesigned
  • Status changed from new to closed

Works as designed.
At a node you change the gas that you use to the left of that node. You are NOT adding a gas change event. You are setting the gas that you used to get to this spot.
That way you change the gas on the first segment by clicking on the first node.
That's how it has always worked in the table as well.

We had the discussion about which way was more intuitive. At the end we flipped a coin (i.e., I decided to do it my way). But that's how it's been designed to work and I sure as heck am not changing this hours before the release.

comment:4 Changed 3 years ago by henrik

  • Priority changed from major to minor
  • Resolution worksasdesigned deleted
  • Status changed from closed to reopened
  • Type changed from defect to enhancement
  • Version changed from 3.9.2 BETA to current git - please provide SHA in your description

No problem, but it's still not very intuitive. I'm proposing this as an enhancement instead.

comment:5 Changed 3 years ago by DirkHH

  • Resolution set to fixed
  • Status changed from reopened to closed

The new planner in git master now does this as requested.
I'll close it - if there's still something to do better, please reopen.

Note: See TracTickets for help on using tickets.