Opened 5 years ago

Closed 4 years ago

#82 closed defect (fixed)

zoop download on windows does not work after cancelling and restarting

Reported by: pkonings Owned by: Subsurface Team
Priority: minor Component: Divecomputer Download
Version: 3.9.1 BETA Keywords:
Cc: Plattform (please give specifics in the ticket text): Windows

Description

(3.0.2 on windows 7 + suunto zoop)

When downloading from the dc has started, you can press two buttons. OK doesn't do anything and should probably be grayed out. Cancel stops the download with the message "Dive data import error". The retry button results in the same error, cancel closes the download dialog.

When you now open the download dialog, you always get the error message. Restarting the dc does not help. Replacing the USB cable does not help. Only restarting subsurface solves the problem.

Change History (4)

comment:1 Changed 4 years ago by DirkHH

It seems we never followed up on this. Is this still valid? Have you tried with later versions of Subsurface (we just released a public beta towards version 4)?

comment:2 Changed 4 years ago by pkonings

This error is still present in 3.9.1 BETA (windows 7), except that the OK button is now grayed out during download. See also this patch by Jef Driesen: http://lists.hohndel.org/pipermail/subsurface/2013-May/006346.html, which should have fixed it.

Last edited 4 years ago by pkonings (previous) (diff)

comment:3 Changed 4 years ago by pkonings

  • Version changed from 3.0.2 to 3.9.1 BETA

comment:4 Changed 4 years ago by Dirk Hohndel <dirk@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 0e3a24c3c058e91b3743a14eaa61ead4cb15c4ea/subsurface:

Reset libdivecomuter import canceled state

Once the process got cancelled once we never reset the flag.

Fixes #82

Initial-fix-by: Jef Driesen
Signed-off-by: Dirk Hohndel <dirk@…>

Note: See TracTickets for help on using tickets.